注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

不懂风情,承蒙错爱。

Making love to Raspberry Pi

 
 
 

日志

 
 
关于我

我爱如莲的少男少女,他们笑容纯真,不说假话。

网易考拉推荐

树莓派apt-get install出错 无法安装其他软件 apt软件源更新  

2013-03-21 10:14:17|  分类: 嵌入式 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
想装个gedit试试,出错了,不知道原因,结果再装别的软件如fswebcam的时候,就不能装了,一直显示gedit的错误。
这个时候怎么办捏,看到很多大神说一旦apt-get出错,就没办法了,只能重装,,,cao

其实解决办法很简单,只要运行:

apt-get remove gedit

卸载掉即可。然后就可以安装其他软件了。

附:更新apt软件源镜像站点方法:
修改

/etc/apt/source.list

即可。替换掉里面的网址。

raspbian给出的镜像站点列表:http://www.raspbian.org/RaspbianMirrors
我用的是清华大学的镜像站,速度很快,教育网内非常好用。前段时间传出要关闭,真是操蛋。幸好解释说只是误会而已。阿弥陀佛。

替换后是没法安装软件的,一定记得先运行一下update命令,更新一下软件源

apt-get update

另外如果要下载软件的话,不用像我这一篇写的这么麻烦了http://stayrunning.blog.163.com/blog/static/19675800220132181042253/
可以这样:

apt-get -d -install packagename

下载的软件包在这里 /var/cache/apt/archives/
树莓派apt-get install出错 无法安装其他软件 apt软件源更新 - 夏天 - 不懂风情,承蒙错爱。
 
  评论这张
 
阅读(3298)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017